Strymon
MultiSwitch

In Stock & Ready to Ship

ALL STRYMON PRODUCTS ARE ONLY AVAILABLE TO CUSTOMERS IN AUSTRALIA Extended control for TimeLine, BigSky, and Möbius Want to unlock the full functionality of TimeLine’s looper? Or discover a new means of exploring presets on TimeLine, BigSky, or Mobius? Connect MultiSwitch to your TimeLine, BigSk...   Read More ›

Strymon MultiSwitch

ALL STRYMON PRODUCTS ARE ONLY AVAILABLE TO CUSTOMERS IN AUSTRALIA


Extended control for TimeLine, BigSky, and Möbius

Want to unlock the full functionality of TimeLine’s looper? Or discover a new means of exploring presets on TimeLine, BigSky, or Mobius? Connect MultiSwitch to your TimeLine, BigSky, or Mobius with the included 1/4" TRS cable and add a new dimension to your rig.

 

Please note: Firmware update is required on your TimeLine, BigSky, or Mobius to enable the Expression Modes compatible with MultiSwitch. A MIDI to USB cable is required for the update. Please visit strymon.net/update for information.

Multiswitch - top down view
  • Connect to TimeLine, BigSky, or Mobius via expression pedal jack
  • Latest TimeLine, BigSky, and Mobius firmware provides several Expression Modes compatible with MultiSwitch:
    Loop Control Mode (TimeLine only)
    Bank Mode
    Preset Mode
    Tap Mode
  • 1/4" right-angle TRS cable included
  • No additional power supply required
  • Rugged gunmetal gray anodized aluminum chassis
  • Small and lightweight
  • Designed and built in the USA

FAQ's

Is a cable included?
Yes, MultiSwitch comes with a 1/4" right angle TRS cable.

Can’t I use a MIDI controller to access the same functions?
Certainly—if you’d like, you can access these features using a MIDI controller. MultiSwitch is geared towards those that don’t want or don’t need to use MIDI in their rigs. MultiSwitch is connected via a TRS cable and does not require a separate power supply.

Do I need to update the firmware on my TimeLine, Mobius, or BigSky to use MultiSwitch?
In most cases yes. Please visit strymon.net/update for information on how to check your firmware version, and how to update your firmware. All TimeLine, Mobius, and BigSky pedals built as of February 17, 2015 ship with firmware that is compatible with MultiSwitch. If your TimeLine, Mobius, or BigSky was built before this date then it will require a firmware update.

What pedals are compatible with MultiSwitch?
MultiSwitch can be used with TimeLine, Mobius, and BigSky.

For all the tutorial videos and more information on this extremely useful pedal, go to Strymon's website.

 

Related Products

< >

FREE SHIPPING AUSTRALIA-WIDE FOR ORDERS $200 AND OVER